Главная

Работа с загрузочным диском WinPE 10-8 Sergei Strelec
Справочное руководство
×

  • Главная
  • Следующая

Работа с загрузочным диском WinPE 10-8 Sergei Strelec

Справочное руководство
2018
(c) Sergei Strelec , conty9 - 2018 - Все материалы собрал вместе OLDMIR


1. О справочном руководстве

Справочное руководство о сборке WinPE 10-8 Sergei Strelec и работе с ней создано на основе материалов описания самой сборки от Sergei Strelec, часто задаваемых вопросов (FAQ) от Sergei Strelec, а также на основе описания программы программы 78Setup и работе с ней от её автора conty9, с одной целью - предоставить пользователям "настольный" вариант справки для удобства работы.
Все материалы предоставляются абсолютно бесплатно и взяты из открытых источников. Все права на материалы данного руководства принадлежат их владельцам.
Автор сборки и мануала по сборке:
Sergei Strelec - www.sergeistrelec.ru
Автор программы 78Setup и мануала по 78Setup:
conty9 - usbtor.ru
Собрал всё вместе:
OLDMIR - lrepacks.ru


2. О сборке WinPE 10-8 Sergei Strelec и работе с ней

Загрузочный диск на базе Windows 10 и 8 PE - для обслуживания компьютеров, работы с жесткими дисками и разделами, резервного копирования и восстановления дисков и разделов, диагностики компьютера, восстановления данных, антивирусной профилактики и установки ОС Windows.

Содержание 2. О сборке WinPE 10-8 Sergei Strelec и работе с ней

2.1. Состав сборки и системные требования
2.2. Подключение сетевых дисков
2.3. Импорт WLAN профилей
2.4. Импорт *.REG файлов
2.5. Замена картинки Рабочего стола
2.6. Что такое пункт загрузки Search & Start Windows 7/8/8.1/10
2.7. Удаление - добавление ярлыков на Рабочем столе
2.8. Обновление сборки
2.9. Установка Windows
2.10. Установка драйверов


2.1. Состав сборки и системные требования

Системные требования:
  • •
    ОЗУ (оперативная память) от 1 ГГб.
  • •
    Компьютер с возможностью загрузки с CD или USB.
Состав сборки:
  • •
    WinPE10x86
  • •
    WinPE10x64
  • •
    WinPE8x86
  • •
    WinPE8x86(Native)


2.2. Подключение сетевых дисков

При подключении сетевых дисков, в поле логин, следует указывать в формате: "имя компьютера\имя пользователя"
Пример: STRELEC-PC\SEREGA
Также и при автомонтировании.
Пример: net use Z: \\STRELEC-PC\J /USER:STRELEC-PC\SEREGA 123456


2.3. Импорт WLAN профилей

WLAN профили следует положить в папку SSTR\MInst\WLANProfile. Импорт производится вручную запуском ярлыка на Рабочем столе или в меню Пуск → Сеть.
Профилей может быть нужное Вам количество. Название профиля должно быть латинскими буквами и не должно содержать пробелов.
Важно: для успешного импорта профиля вначале необходимо установить WLAN драйвера.


2.4. Импорт *.REG файлов

Собственные REG файлы следует положить в папку SSTR\MInst\Registry. При загрузке данные будут внесены в реестр WinPE.
Зачем это надо:
Например, Вы добавили свою программу, которая требует внесение данных в реестр. То есть это можно сделать без перепаковки wim файла.


2.5. Замена картинки Рабочего стола

Если Вы хотите поменять картинку Рабочего стола, вы должны положить Вашу картинку в папку SSTR\MInst\Wallpaper вместо существующей Wallpaper.jpg под таким же названием (то есть заменить на свою).


2.6. Что такое пункт загрузки Search & Start Windows 7/8/8.1/10

При выборе этого пункта выполняется поиск и запуск (если найден) windows\system32\winload.exe (winload.efi). То есть система грузится напрямую минуя загрузчик, BCD....
Этот вариант не является панацеей для лечения... но это поможет загрузить Windows, если запись MBR/PBR повреждена, загрузчик bootmgr на жестком диске, BCD, другие файлы из загрузочного раздела или проблема с самим разделом.
После загрузки ОС (она может загрузиться неактивированной - это нормально, зависит от метода активации), потребуется только восстановить файлы загрузки (если они были, конечно, повреждены) обычными или сторонними утилитами.
*Без особой необходимости этот метод не рекомендуется.


2.7. Удаление - добавление ярлыков на Рабочем столе

Вы можете как удалить ненужные Вам существующие, так и добавить собственные ярлыки на Рабочий стол. Для этого необходимо отредактировать профиль программы MinstAll.
Как это сделать можно посмотреть видео (Youtube):
*Для просмотра требуется подключение к интернету
https://youtu.be/DKa_CpvqzMY


2.8. Обновление сборки

Если у Вас есть флешка с моей сборкой, достаточно удалить ее с флешки и распаковать туда новый образ. Форматировать или перезаписывать лишний раз не стоит.


2.9. Установка Windows

  • 1.
    Программой WinNTSetup. Устанавливает любую версию Windows непосредственно из *.wim файла или ISO образа.
  • 2.
    Программой 78Setup (от conty9) - Полное описание программы 78Setup (от conty9)
  • 3.
    Из смонтированного образа (с пом. штатного Setup.exe) устанавливается любая версия Windows, НО соответствующая разрядности загруженного образа WinPE.
Примечание: Некоторые сборщики дистрибутивов удаляют возможность установки OS из под Windows.
Дополнительно: На диске Х лежит папка Autounattend с файлами ответов для автоматической установки русской версии Windows. При установке Windows 7-10 x86/x64 с помощью WinNTSetup или 78Setup на него следует указать в соответствии с устанавливаемой системой.
Видео: Установка Windows с Boot USB Sergei Strelec (YouTube)
*Для просмотра требуется подключение к интернету
https://youtu.be/tdOWx81EvWY
Видео: Установка Windows в режиме UEFI программой WinNTSetup (YouTube)
*Для просмотра требуется подключение к интернету
https://youtu.be/b1-GLTNtgJo


2.10. Установка драйверов

Для того чтобы Ваши драйверы установились при загрузке WinPE - положите их на вашу загрузочную флешку в папки SSTR/USER/MY_DRIVERS_x64 или SSTR/USER/MY_DRIVERS_x86. Они будут установлены автоматически.
В основном этот способ используется для установки драйверов контроллеров, если в WinPE отсутсвует необходимый, WLAN драйверов и.т.д.
Примечание: Не ложите туда объемные или ненужные драйверы.
Важно: подпапки не должны иметь пробелы в имени, названия - ТОЛЬКО латиница


3. Полное описание программы 78Setup (от conty9)

78Setup (классическая установка Windows 7/8/8.1/10 из набора дистрибутивов)
Утилита позволяет держать наборы установочных дистрибутивов ОС Windows 7/8/8.1 (возможно, и 10) в 3 папках (папки указываются в конфигурационном файле 78setup.cfg). Поддерживается обработка как распакованных дистрибутивов, так и образов дисков (для работы с образами, при необходимости, устанавливается ImDisk). При запуске утилита сканирует указанные в конфигурации папки на всех дисках (обрабатываются все подкаталоги указанных папок) и формирует списки найденных дистрибутивов и списки образов дисков. Дополнительно сканируются распакованные в корень дисков дистрибутивы (папка Sources). Количество дистрибутивов не ограничено (в разумных пределах), полсотни отображается без проблем.
Несмотря на "обилие" кнопок, в обычном варианте использования программа довольно несложная. В общем случае, следует определиться, из какого варианта дистрибутива будем устанавливать ОС: из распакованного ("Классическая установка из папки дистрибутива") или из образа диска ("Классическая установка из образа дистрибутива"). Выбираем в соответствующей панели нужный дистрибутив (из найденных или, при необходимости, вручную), нажимаем "Установить". Откроется окно выбора параметров установки. В нем по-умолчанию будет оптимальный выбор среды установки, папки $OEM$ и сценария установки (при необходимости, их тоже можно сменить). Останется только нажать "Запуск" - и запустится классическая установка ОС...
Подробнее - кнопки, что и как:
1. Вызов диспетчера задач. Есть хоткей вызова TaskMgr (кнопка Break/Pause), хоткей работает, пока запущена 78setup.
2. Панель выбора разрешения (800х600 или 1024х768). Если выбрано разрешение, отличное от указанных, установка разрешения будет заблокирована (считается, что под РЕ есть полноценный режим выбора разрешения).
3. Панель оперативной смены языка 78setup (при запуске утилита автоматически определяет язык РЕ/ОС, и, если он русский, тогда устанавливается русский интерфейс, если нет - английский). При оперативной смене языка также происходит обновление доступных HDD и заново производится поиск дистрибутивов на всех дисках (аналогично п.4).
4. Обновить HDD. Будет произведен повторный поиск дистрибутивов (актуально, если был подключен новый носитель) без перезапуска программы. При этом добавленные вручную дистрибутивы из меню будут удалены.
5. Информация о системе: для WinPE вид загрузки (BIOS/UEFI), тип ОС/РЕ (индикация Windows / WinPE), разрядность (х86, х64, если в х64 поддерживается подсистема х86, тогда х64|86), русская или нет (Rus/Eng, для других - индикация DOS-кодовой странички, например CP:936 для китайской WinPE).
6. Имя запущенной ОС/РЕ.
7. Диск, с которого запущена утилита.
8. Имя процессора и его частота.
9. Доступный под данной ОС/РЕ объем ОЗУ (для х64 - полный объем, для х86 без поддержки РАЕ - ограничено 3,2...3,7Гб).
10. Панель установки из папки распакованного дистрибутива
11. Выбор дистрибутива. Поиск ведется по маскам install*.wim, install*.esd, install.swm. Все найденные варианты добавляются в меню выбора. В последнюю очередь производится поиск в корневых папках Sources (независимо от настроек папок для поиска), последний найденный вариант будет выбран по-умолчанию.
12. Описание дистрибутива из файла install*.wim/esd/swm.txt (т.е., имя должно быть то же, что и у установочного архива, но с дополнительным расширением .txt). Текст в одну строку, кодировка 1251, до 70-80 символов. Нельзя использовать спецсимволы и запятую - в общем пробуйте, если будет "неудобный" символ - описание будет обрезано/уменьшено/отсутствовать.
13. Ручной выбор дистрибутива (откроется окно обзора файлов, маска *.wim/*.esd/*.swm). Выбраный дистрибутив будет добавлен в меню (п.11) и выбран по умолчанию.
14. Состояние среды установки в папке X:\Sources. Если среда отсутствует, надпись серым цветом, если имеется - черным. Если среда отсутствует, но имеется её архив (файлы sources.7z и sources64.7z в подкаталоге Utilites), после запуска 78setup архив будет распакован в фоновом режиме, после чего индикация изменится.
15. Запуск DiskPart в отдельном окне.
16. Запуск установки (с возможностью среды установки, OEM и сценария установки). Если среда установки отсутствует, установка будет возможна только при помощи WinNTsetup.
17. Панель установки из образа диска дистрибутива
18. Подсказка по хоткею ('Alt+Break') для прерывания установки ОС или работы MS DaRT.
19. Выбор образа дистрибутива. Поиск ведется по маскам *.iso, *.nrg, *.bin (эти форматы поддерживает ImDisk). Все найденные варианты добавляются в меню выбора.
20. Индикация текущего (выбранного) образа для использования.
21. Ручной выбор образа. После выбора будет добавлен в меню (п.19) и выбран по-умолчанию.
22. Индикация папки V:\Sources смонтированного образа.
23. Окно управления ImDisk (можно подключить образ с любой свободной буквой диска или отключить завиртуаленный).
24. Запуск установки. Перед запуском (при необходимости) монтируется новый образ. Под РЕ (если имеется трей-бар), после монтирования отображается всплывающее сообщение в трее. Дальше - аналогично п.16, но для установки будет выбран дистрибутив из папки V:\Sources.
U1. Панель утилит. Может отключаться в настройках 78setup.cfg, при этом панель будет отсутствовать, хоткеи панели отключаются.
U2-5. Штатные утилиты 78setup: блокнот, файл-менеджер JustManager /хоткей 'F11'/, запуск среды восстановления / DaRT (если отсутствует по пути X:\sources\recovery\RecEnv.exe, неактивна), BootICE (если отсутствует WinNTsetup скрыта).
U6-9. Пользовательские утилиты 78setup. В конфигурационном файле (78setup.cfg) можно указать:
а) имена утилит (UserX=, где X - 1...4), отображаемые на кнопках
б) пути их запуска (UserX.86=/UserX.64= для среды х86 и х64 соответственно), путь может быть как относительным (относительно 78Setup.exe, например, Utilites\SnapShot.exe), так и полным (X:\Windows\regedit.exe)
* Если заранее известно, что будет использована WinPE x64 с поддержкой подсистемы x86, можно указать одно и тоже (путь к х86-версии утилиты)
** Если путь к утилите (соответствующей разрядности ОС/РЕ) не указан либо неверен, кнопка её запуска будет невидима.
U10. Переход к окну "Перезагрузка". В нем выводится соответствующее предупреждение, и возможна перезагрузка или выключение ПК. Перед выключением извлекаются все носители (CD/DVD).
* Под РЕ-установщиками перезагрузка также возможна, если по Alt+F4 закрыть 78setup (используемый в качестве оболочки), в этом случае произойдет завершение сеанса работы - что для РЕ-установщика вызовет перезагрузку.
** После использования среды восстановления (если выйти из программы) происходит перезагрузка. Если это нежелательно, не выходя из DaRT, снимите процесс RecEnv.exe в диспетчере задач или по хоткею 'Alt+Break' (п.18).

Содержание 3. Полное описание программы 78Setup (от conty9)

3.1. Выбор параметров установки
3.2. Назначение файлов
3.3. Маски для поиска установочных файлов
3.4. Примерный файл конфигурации 78setup.cfg


3.1. Выбор параметров установки

1. Индикация папки дистрибутива
2. Индикация описания (если имеется). Для образов (если в образе нет описания), индицируется полный путь к образу.
3. Панель выбора среды установки. Максимально возможны 3 варианта: а) Distributive - среда имеется в папке дистрибутива и подходит для использования; б) X:\Sources - среда имеется в X:\Sources (либо была распакована из заготовки Utilites\sources*.7z); в) .\Utilites - если при запуске 78setup среда уже имеется в X:\Sources, но может быть использована из заготовки Utilites\sources*.7z. Отображается разрядность и версия среды установки.
* В утилите производится предварительный поиск файлов в каталогах дистрибутива и X:\Sources. Найденные файлы анализируются по разрядности (х86/х64) и добавляются в это меню. Для использования будут доступны только те варианты, которые совместимы с текущей системой (т.е., для WinPE х86 - только х86, а для WinPE х64 без поддержки подсистемы х86 - только х64). Кроме разрядности файла установки, важную роль играет разрядность среды установки (библиотек рядом с setup.exe) - она должна соответствовать разрядности setup.exe, только при таких условиях возможна установка. Если имеется среда установки в X:\Sources, то там 100% нужная среда.
4. Панель выбора папки OEM-установки и сценария. По-умолчанию, автоматически выбираются из папки дистрибутива (если отсутствуют в дистрибутиве, пункты неактивны). Также возможен ручной выбор (если произведен выбор, пункт активируется).
5. Отмена, выход в главное меню программы.
6. Проверка архива выбранного дистрибутива (файл install*.win/esd/swm/rwm) на целостность с помощью WimLib (откроется DOS-окно с информацией о состоянии и результате проверки).
7. Запуск установки ОС с помощью WinNTsetup. Программа позволит установить ОС даже при отсутствии среды установки. При этом настройки (выбранный дистрибутив, сценарий установки) будут автоматически добавлены в WinNTsetup, а в качестве целевого диска для ОС и загрузчика будет выбран С:\.
* WinNTsetup поддерживает папку OEM-установки исключительно из папки дистрибутива. Т.е., если в дистрибутиве имеется Sourses\$OEM$, то OEM-установка производится из нее автоматически. Если же папка OEM-установки выбрана вручную (из другого каталога), то OEM-установка произведена не будет.
8. Запуск классической установки с выбранными настройками.
Примечания:
* Если не работает мышка, используйте Tab для перехода по кнопкам (Shift+TAB - переход в обратном порядке) и Enter/Space для выполнения.
** Кнопки недоступных операций блокируются автоматически.
*** Допускается размещение в одной и той же папке разных версий дистрибутивов с разными именами: install.swm (только один комплект, поскольку он может состоять из нескольких файлов, например install.swm, install1.swm, install2.swm и т.д.), неограниченного числа installXXX.wim (install_7x86.wim, install_8x86.wim и т.д., по маске install*.wim) и installXXX.esd (install_8x86.esd, install_8.1x86.esd и т.д., по маске install*.esd). Все эти дистрибутивы будут добавлены в меню. Описание конкретного дистрибутива должно соответствовать его имени с дополнительным расширением txt, например, install_7x86.wim.txt. При этом учитываем, что среда установки, ОЕМ и сценарий установки будут общими.
**** Начиная с версии 2.3, 78setup при поиске пропускает (игнорирует) файлы размером менее 256Мб. Т.е., такие файлы не включаются в список выбора дистрибутивов и их образов. Но, при желании, их можно выбрать вручную.


3.2. Назначение файлов

78Setup.exe - х86 версия утилиты. Если в РЕх64 имеется подсистема х86, тоже будет работать (т.е., в таком случае её достаточно).
78Setup64.exe - х64 версия. Предназначена исключительно для х64 РЕ-установщиков без подсистемы х86.
78setup.cfg - конфиг. Можно удалять, если не нужен (читаем в нем самом описание). Если отсутствует, автоматически включается панель утилит.
Utilites\JustManager\ - файл-менеджер. Если не нужен, можно удалить (кнопка станет неактивной).
Utilites\sources*.7z - SFX-самораспаки среды установки (то, что будет распаковано в X:\Sources), в 2.0 используется среда установки от 10-ки. Версии для х86 и х64. Если не нужно, удаляем.
Utilites\ImDisk*.7z - SFX-самораспаки инсталятора ImDisk. Версии для х86 и х64. Если не нужно, удаляем. Если отсутствуют и в WinPE нет ImDisk, кнопки операций с виртуальными дисками блокируются.
Utilites\WinNTSetup*.exe - SFX-самораспаки WinNTSetup (x86 + x64). Если отсутствуют, из главного меню исчезнет кнопка запуска BootICE, а из меню установки - проверка архивов с помощью WimLib и установка ОС с помощью WinNTsetup.
Utilites\DaRTex*.exe - Explorer DaRT 6.0. Проводник из комплекта DaRT. Примечателен тем, что без проблем работает с запароленными (NTFS) папками. Работает только в среде WinPE.
Utilites\SnapShot*.exe - небольшой, но очень функциональный бекаппер Drive SnapShot.
Utilites\P_Assistant*.exe - Aomei Partition Assistant, довольно продвинутый менеджер дисков. Позволяет конвертировать MBR<>GPT.
Utilites\ShadowProtect*.exe - отличный бекаппер. Позволяет создавать как обычные, так и инкрементные архивы, умеет их проверять и монтировать. Также есть функция адаптации ОС под новое железо (HIR, работает только в х86-версии), менеджер дисков и многое другое.
Папка Translate - в ней находятся заготовки для перевода интерфейса на другие языки, описание в read.txt. Для работы программы не нужна.
* В 78Setup необязательно использовать полный набор файлов. Если среда установки есть в РЕ, тогда можно удалить Utilites\sources*.7z. Если РЕ на базе х64 обладает поддержкой х86-подсистемы, то х64-версии утилит можно удалить (оставить нужно лишь драйвер ImDisk64.7z - если он отсутствует в РЕ х64). Если в WinPE уже установлен ImDisk, тогда Utilites\ImDisk*.7z не нужны. Если дополнительные утилиты (JustManager, DaRTex, SnapShot, P_Assistant, ShadowProtect) не нужны, их также можно удалить полностью или по выбору (либо заменить пользовательский набор своим).


3.3. Маски для поиска установочных файлов

Для файла установки (setup.exe в оригинальном дистрибутиве): set????.exe (т.е., будут найдены файлы setup.exe, set64.exe, setup64.exe, setup32.exe)
Для дистрибутивов: install.swm, install*.wim, install*.esd
Для образов дисков: *.iso, *.nrg, *.bin
Для папок OEM: *OEM?
Для сценариев установки: *unattend.xml
Проверка х64 - наличие папки %WinDir%\SysWOW64
Проверка подсистемы х86 в х64 - наличие файла %WinDir%\SysWOW64\regedit.exe


3.4. Примерный файл конфигурации 78setup.cfg

DistrFolder1-3 - Folder names to search for distributives OS (unpacked)
ISOfolder1-3 - Folder names to search for ISO-images distributives OS
UtilitesPanel - The utilites panel: allow (any character) or hidden (0)
========================== CODEPAGE 1251 ===============================
DistrFolder1=\_ISO
DistrFolder2=\_ISO
DistrFolder3=\Мои дистрибутивы\Тут
IsoFolder1=\_ISO
IsoFolder2=\_ISO
IsoFolder3=\Тут образы
UtilitesPanel=1
LetterSwap=1
Sources.7z=10.0.10240
User1=Drive SnapShot
User1.86=Utilites\SnapShot.exe
User1.64=Utilites\SnapShot64.exe
User2=MS-DaRT Explorer
User2.86=Utilites\DaRTex.exe
User2.64=Utilites\DaRTex64.exe
User3=Partition Assistant
User3.86=Utilites\P_Assistant.exe
User3.64=Utilites\P_Assistant64.exe
User4=ShadowProtect
User4.86=Utilites\ShadowProtectPE.exe
User4.64=Utilites\ShadowProtect64.exe
Примечания:
1. Строчки 1-4 игнорируются (описание).
2. Если не нужно искать по 3 папкам, указываем только первую папку DistrFolder1/IsoFolder1 (а 2/3 оставляем пустыми), или 1-ю и 2-ю.
3. Если не указаны папки для поиска 1 и 2 (не заполнены либо переменная вообще отсутствует), производится поиск по-умолчанию в рабочей папке (все подкаталоги тоже обрабатываются) и в корневых папках _ISO. То же произойдет, если настроечный файл 78setup.cfg отсутствует.
4. Поиск папок ведется по всем дискам, и все найденные результаты будут добавлены в меню выбора. Для распакованных дистрибутивов дополнительно производится поиск в корневых каталогах Sources.
5. Если в качестве строки поиска указать только обратный слеш \, то производится поиск по всем дискам и всем каталогам/подкаталогам. Но это очень длительный процесс - до десятка минут (зависит от количества дисков/папок/файлов). Не рекомендуется к использованию - будет казаться, что утилита подвисла!!!
6. Для включения панели утилит служит параметр UtilitesPanel=1. При значении '0' или отсутствии файла конфигурации панель отключена.
7. Для включения режима автосортировки буковок дисков служит LetterSwap=1. При значении '0' или отсутствии этого параметра в файле конфигурации автосортировка отключена. Также отключается, если системный диск не X:\ или в системном каталоге присутствует файл letterswap*.* (тогда считается, что в WinPE есть свой метод сортировки). Результат автосортировки: при наличии ОС на любом из HDD буквы будут отсортированы согласно ОС, при отсутствии ОС - вначале разделы первого HDD (активный раздел - первым), потом - второго, и т.д.., потом - CD/DVD, в последнюю очередь - флешки и USB-HDD (начиная с буковки Q).
8. Для указания версии заготовок Sources*.7z служит параметр Sources.7z=10.0.10240. Параметр необязателен, при его отсутствии версия в 3-в) в "Выбор параметров установки" не указывается.
9. Для указания имени кнопки пользовательской утилиты 1 служит User1= (в примере Drive SnapShot), при этом в User1.86 указываем путь запуска х86-версии утилиты, а в
User1.64 - х64 версии (для х64 с поддержкой подсистемы х86 допустимо использование х86-версии, для этого в User1.64 указываем то же, что и в User1.86). Для пользовательских утилит 2-4 - аналогично.
* Можно указать путь:
1. Для любой папки на том же разделе, что и 78setup (используем переменную %CurDrv%). Например, %CurDrv%\2k10\Programs-2k10\FileManager\TotalCmd\TC.exe для запуска ТС из программного пакета 2k10.
2. Указать полный путь - т.е., только для программ на системном диске. Например, X:\Program Files\TC\TC.exe.
3. Указать относительный путь (относительно папки, где лежит 78Setup.exe). Например, ..\..\2k10\Programs-2k10\FileManager\TotalCmd\TC.exe. "..\" - означает перейти на уровень выше, чем находится программа, "..\..\" - на два уровня.
* Даже при наличии пробелов или кирриличных символов путь в кавычки брать НЕ НУЖНО.


4. Часто задаваемые вопросы (F.A.Q) - Автор Sergei Strelec

Важно: для редактирования конфигурационных (.cfg | .ini | .lst и.т.п.) а также командных (.cmd | .bat и.т.п.) файлов используйте AkelPad или Notepad++

Содержание 4. Часто задаваемые вопросы (F.A.Q) - Автор Sergei Strelec

4.1. Зачем нужна ваша сборка и какова ее структура?
4.2. Как лучше загружать вашу сборку: напрямую из файла-образа или распаковывать?
4.3. Как добавить вашу сборку на загрузочную/мультизагрузочную флешку?
4.4. Как загружать вашу сборку с флешки, но напрямую из файла-образа?
4.5. Как загружать вашу сборку, если PC современный (UEFI) и вообще не поддерживает режим Legacy?
4.6. Хочу обновить вашу сборку на флешке, как это сделать?
4.7. Как создать "с нуля" загрузочную флешку и перепаковать встроенные программы?
4.8. Какой программой лучше форматировать флешку?
4.9. Можно ли для создания загрузочной флешки использовать форматирование NTFS?
4.10. Как протеcтировать загрузку вашей сборки на VMware Workstation в режиме UEFI?
4.11. Работает ли в режиме UEFI загрузчик Grub4Dos?
4.12. Ошибка в VirtualBox: "Нужно расширение физических возможностей для поддержки систем ОЗУ с 4Гб"
4.13. Как отредактировать загрузочное меню вашей сборки?
4.14. Подходит ли ваша сборка для "древних" PC с объёмом RAM от 256mb и менее?
4.15. Как загрузить вашу сборку на PC где CPU не поддерживает NX инструкции?
4.16. Что такое "нативный" режим загрузки (Native Mode)?
4.17. Как установить Win8 на неразмеченный HDD в режиме UEFI + GPT с помощью WinNTSetup?
4.18. Ошибка Gimagex: "Opening WIM...please wait... ERROR: Unable to mount image."
4.19. Как в вашей сборке увеличить размер диска Boot(X:)?
4.20. Как в вашей сборке заменить обои на "Рабочем Столе" на собственные, но без изменения WIM-файла?
4.21. Как загрузить вашу сборку если на PC не установлена Windows, нет Floppy и CD-DVD приводов и BIOS не поддерживает загрузку с флешки?
4.22. Как добавить к вашей сборке какой-нибудь дистрибутив Linux Live?
4.23. Как добавить в меню вашей основной сборки загрузку "Acronis Boot CD/USB Sergei Strelec"?
4.24. Как самостоятельно обновить программу SmartFix в вашей сборке?
4.25. Как добавить в вашу сборку возможность использования языка ввода и раскладки клавиатуры, отличных от Русского и Английского?
4.26. Как внести собственные изменения/дополнения в реестр вашей сборки?
4.27. Как можно сделать экспорт/импорт WLAN-профилей, чтобы не вводить данные каждый раз вручную?
4.28. Я нашел/написал по-моему потрясающую программу/скрипт. Как выложить ее на вашем сайте?
4.29. Зачем нужны патчи-обновления для вашей сборки и как применять эти патчи?
4.30. Как добавить в вашу сборку образ Kaspersky Rescue Disk 10?
4.31. Как установить/переустановить Windows с помощью вашей сборки?
4.32. Почему в режиме UEFI ваша сборка (x64) загружается, а (x86) не хочет, хотя на планшетах ситуация обратная?


4.1. Зачем нужна ваша сборка и какова ее структура?

Сборка Boot USB Sergei Strelec - загрузочный диск для диагностики и обслуживания компьютеров, восстановления работоспособности ОС,
резервного копирования и восстановления данных, антивирусной профилактики.
Структура загрузочного образа:
EFI - Каталог с загрузчиками, конфигурацией загрузки и другими файлами, необходимыми ТОЛЬКО для UEFI .
rescue - Каталог с файлами для Kaspersky Rescue Disk.
SSTR - Главный каталог сборки.
bootmgr - Mенеджер загрузки (не используется в UEFI ).
liveusb - Компонент для Kaspersky Rescue Disk (файл-маркер).
Структура основного каталога сборки:
_WIN - Каталог для установочных файлов/образов Windows
78Setup - Специальная утилита для работы с каталогом _WIN
DOS - Каталог с программами, работающими в среде MS-DOS (недоcтупно в режиме UEFI )
DriverPacks - Каталог с минимальным набором драйверов для WinPE
MInst - Каталог с портативными приложениями и удобной программой-оболочкой для их запуска.
USER - Каталог для пользовательских файлов(на данный момент поддерживаются только драйверы)
BCD - Файл конфигурации для BOOTMGR (не используется в UEFI )
boot.sdi - Важный компонент загрузки (system deployment image)
bootmgr - Файл-копия менеджера загрузки (не используется в UEFI ).
grldr - Mенеджер загрузки " Grub for Dos " (не работает в UEFI )
menu.lst - Файл конфигурации для " Grub for Dos " (не используется в UEFI )
strelec8NE.wim - Микро-ядро Windows8 x86(только для Native режима)
strelec8.wim - Ядро Windows8 x86
strelec10.wim - Ядро Windows10 x86
strelec10x64.wim - Ядро Windows10 x64


4.2. Как лучше загружать вашу сборку: напрямую из файла-образа или распаковывать?

Рекомендуется загружать распакованную сборку, но окончательный выбор за вами (см.

Как добавить вашу сборку на загрузочную/мультизагрузочную флешку?

 и Как добавить вашу сборку на загрузочную/мультизагрузочную флешку? ).


4.3. Как добавить вашу сборку на загрузочную/мультизагрузочную флешку?

Для мультизагрузочной флешки:
Если флешка на основе загрузчика Grub4Dos :
1. Извлечь из образа каталог SSTR в "корень" флешки
2. Добавить в файл MENU.LST следующее:
title Boot USB Sergei Strelec 2014
find --set-root --ignore-floppies /SSTR/BOOTMGR
chainloader /SSTR/BOOTMGR
Для загрузочной флешки:
Понадобится физически исправная флешки, объем от 4 до 32GB и формат файловой системы FAT32 можно считать вполне достаточными условиями.
1. Открыть файл-образ сборки(iso) в программе UltraISO, перейти в меню "Самозагрузка" - Записать Образ Жесткого Диска" и записать загрузочную флешку.
Удалять или перемещать какие-либо файлы/каталоги в сборке, не имея понятия о структуре данной сборки и назначении этих самых файлов/каталогов - НЕ рекомендуется.


4.4. Как загружать вашу сборку с флешки, но напрямую из файла-образа?

Понадобится исправная загрузочная флешка на основе загрузчика Grub4Dos .
Начиная с Boot USB Sergei Strelec 2014 v7.1 в сборку интегрирован FiraDisk Driver (File/RAM Disk driver for Windows), что позволяет без проблем загружать сборку напрямую с файла-образа.
Для этого в файл menu.lst на загрузочной флешке следует добавить следующее:
#
iftitle [if exist /iso/strelec.iso] Boot Strelec 2014 from ISO
map --mem (md)+4 (99)
map /iso/strelec.iso (0xff)
map (hd0) (hd1)
map (hd1) (hd0)
map --hook
write (99) [FiraDisk]\nStartOptions=cdrom,vmem=find:/iso/strelec.iso;\n\0
chainloader (0xff)
#
где "/iso/strelec.iso" это полный путь от корневого каталога загрузочной флешки до файла-образа сборки.
Атрибут "Read Only"(Только Чтение) у файла-образа(.iso) должен быть снят, не забываем проверить это.
Дефрагментация файла-образа обязательна, в противном случае образ сможет загрузиться только в RAM.
Для дефрагментации можно использовать, например, бесплатную программу Defraggler


4.5. Как загружать вашу сборку, если PC современный (UEFI) и вообще не поддерживает режим Legacy?

Все очень просто - загружайте х64 версию сборки, а загрузочная флешка должна быть отформатирована в FAT32 (см. Какой программой лучше форматировать флешку? )


Работа с загрузочным диском WinPE 10-8 Sergei Strelec
Справочное руководство
×

  • 4. Часто задаваемые вопросы (F.A.Q) - Автор Sergei Strelec
  • 4.6. Хочу обновить вашу сборку на флешке, как это сделать?
  • Предыдущая
  • Следующая

4.6. Хочу обновить вашу сборку на флешке, как это сделать?

Просто удалите с флешки файлы сборки и распакуйте туда новые. Форматировать флешку не обязательно.


4.7. Как создать "с нуля" загрузочную флешку и перепаковать встроенные программы?

Несколько устаревшее (в связи с появлением различных концептуальных программ) "видео-руководство" можно скачать здесь .


Работа с загрузочным диском WinPE 10-8 Sergei Strelec
Справочное руководство
×

  • 4. Часто задаваемые вопросы (F.A.Q) - Автор Sergei Strelec
  • 4.8. Какой программой лучше форматировать флешку?
  • Предыдущая
  • Следующая

4.8. Какой программой лучше форматировать флешку?

HP USB Disk Storage Format Tool 2.2.3


4.9. Можно ли для создания загрузочной флешки использовать форматирование NTFS?

Да, можно. Но тогда загрузка PC в режиме UEFI будет невозможна.
Инструкция:
1. Форматируем флешку в NTFS, лучше программой HP USB Disk Storage Format Tool
2. Запускаем программу BOOTICE 1.3.2 и внимательно смотрим, чтобы в поле "Destination Disk" отображалась флешка
3. Нажимаем "Process MBR" и выставляем "UltralSO USB-HDD+", затем нажимаем "Install /Config"
4. Нажимаем "Process PBR" и выставляем "BOOTMGR boot record", затем нажимаем "Install /Config"
5. Нажимаем "Parts Manage", выделяем там нашу флешку и нажимаем "Activate" (т.е. делаем ее активной, иначе не загрузится)
6. Распаковываем образ программой UltralSO в корневой каталог флешки и все, флешка готова - можно пробовать с нее загружаться.
Необходимый набор программ (без UltralSO) можно скачать здесь


4.10. Как протеcтировать загрузку вашей сборки на VMware Workstation в режиме UEFI?

1. Создайте мастером новую чистую виртуальную машину (не включайте ее!)
2. Открыть в блокноте конфигурационный файл этой виртуальной машины (файл с расширением *.vmx) и в начале файла добавить строку
firmware="efi"
Конфигурационный файл искать в:
%USERPROFILE%\Documents\Virtual Machines\%ИМЯ ВИРТУАЛЬНОЙ МАШИНЫ%\*.vmx
Что в переводе на "человеко-понятный" звучит как: в каталоге "Мои Документы"


Работа с загрузочным диском WinPE 10-8 Sergei Strelec
Справочное руководство
×

  • 4. Часто задаваемые вопросы (F.A.Q) - Автор Sergei Strelec
  • 4.11. Работает ли в режиме UEFI загрузчик Grub4Dos?
  • Предыдущая
  • Следующая

4.11. Работает ли в режиме UEFI загрузчик Grub4Dos?

Нет, не работает.


4.12. Ошибка в VirtualBox: "Нужно расширение физических возможностей для поддержки систем ОЗУ с 4Гб"

Нужно включить в настройках созданной виртуальной машины поддержку PAE (Расширение физических адресов).


4.13. Как отредактировать загрузочное меню вашей сборки?

Загрузочное меню режима Legacy находитcя в файле "SSTR\BCD".
Загрузочное меню режима UEFI находитcя в файле "efi\microsoft\boot\BCD".
Редактируется с помощью утилит "BootIce v.1.3.2" или "Easy BCD". Обе утилиты присутствуют в составе сборки.


Работа с загрузочным диском WinPE 10-8 Sergei Strelec
Справочное руководство
×

  • 4. Часто задаваемые вопросы (F.A.Q) - Автор Sergei Strelec
  • 4.14. Подходит ли ваша сборка для "древних" PC с объёмом RAM от 256mb и менее?
  • Предыдущая
  • Следующая

4.14. Подходит ли ваша сборка для "древних" PC с объёмом RAM от 256mb и менее?

Нет, не подходит. Посмотрите в сторону сборок WinPE на базе WinXP/2003.


Работа с загрузочным диском WinPE 10-8 Sergei Strelec
Справочное руководство
×

  • 4. Часто задаваемые вопросы (F.A.Q) - Автор Sergei Strelec
  • 4.15. Как загрузить вашу сборку на PC где CPU не поддерживает NX инструкции?
  • Предыдущая
  • Следующая

4.15. Как загрузить вашу сборку на PC где CPU не поддерживает NX инструкции?

Рекомендуется: загрузить сборку в "Native Mode" (в загрузочном меню будет соответствующий пункт).


4.16. Что такое "нативный" режим загрузки (Native Mode)?

Это специальный режим, в котором сначала загружается специально подготовленное минимальное ядро (без графической оболочки) и отрабатывает скрипт, который производит поиск носителя (DVD, USB-HDD) со сборкой и монтирует "полное" ядро.
+Плюсы:
1. Быстрая загрузка на USB 1.x. Вместо обычных 5-10 мин на USB 1.2 - около 1 минуты.
2. Меньшее потребление памяти (для сборки Strelec - меньше на ~250Мб).
3. Пониженные требования к CPU (ядро Native Mode пропатчено для работы с CPU начиная с P4/Athlon), отключена проверка NX-бита.
-Минусы:
1. Привязка к носителю (при его извлечении - PC "зависнет").
2. Более медленная работа ядра (поскольку всё загружается не из быстрого РАМ-диска, а c медленного носителя). На практике особых "тормозов" не ощущается.
3. Некорректно работает RunScanner (утилита для перенаправления программ на работу с реестром целевой ОС), перенаправления на реестр целевой ОС не происходит.
4. Для совместимости со старыми CPU отключена поддержка мультиядерности и РАЕ.
Примечание: На современных PC лучше использовать обычный режим загрузки.


4.17. Как установить Win8 на неразмеченный HDD в режиме UEFI + GPT с помощью WinNTSetup?

1. Переключаем режим загрузки PC из "Legacy" в "UEFI" и грузим с флешки Boot_USB_Sergei_Strelec x64
2. Жмем WIN+R, вводим CMD, затем DISKPART
3. Вводим команду:
list disk
и получаем нумерованный список дисков. В данном примере целевой HDD имеет номер "0".
Далее выполняем рекомендации от msdn.microsoft.com :
1. Создаем на флешке текстовый файл с именем gpt.txt с таким содержанием:
rem == CreatePartitions-UEFI.txt ==
rem == These commands are used with DiskPart to
rem create five partitions
rem for a UEFI/GPT-based PC.
rem Adjust the partition sizes to fill the drive
rem as necessary. ==
select disk 0
clean
convert gpt
rem == 1. Windows RE tools partition ===============
create partition primary size=300
format quick fs=ntfs label="Windows RE tools"
assign letter="T"
set id="de94bba4-06d1-4d40-a16a-bfd50179d6ac"
gpt attributes=0x8000000000000001
rem == 2. System partition =========================
create partition efi size=100
rem ** NOTE: For Advanced Format 4Kn drives,
rem change this value to size = 260 **
format quick fs=fat32 label="System"
assign letter="S"
rem == 3. Microsoft Reserved (MSR) partition =======
create partition msr size=128
rem == 4. Windows partition ========================
rem == Create the Windows partition ==========
create partition primary
rem == Create space for the recovery image ===
shrink minimum=15000
rem ** NOTE: Update this size to match the size
rem of the recovery image **
rem == Prepare the Windows partition =========
format quick fs=ntfs label="Windows"
assign letter="W"
rem === 5. Recovery image partition ================
create partition primary
format quick fs=ntfs label="Recovery image"
assign letter="R"
set id="de94bba4-06d1-4d40-a16a-bfd50179d6ac"
gpt attributes=0x8000000000000001
list volume
exit
где в "select disk 0" - "0" это номер, полученный после команды "list disk" (у вас может быть другим!)
Важно: Если в PC установлено более одного HDD, то номер диска определяет: разметка какого-именно HDD будет изменена с потерей всех данных на нём.
2. Запускаем консоль CMD и вводим:
diskpart /s H:\gpt.txt
Путь к файлу gpt.txt соответственно меняем на свой.
После отработки сценария раздел с label="Windows" можно разделить "по желанию" в любом современном менеджере разделов.
Теперь можно указать WinNTSetup на install.wim от win 8.*x64 или win 10.*x64
"Загрузчик" необходимо устанавливать на раздел с label="System".
Операционную систему лучше устанавливать на первый раздел после раздела MSR (размер 128mb).
Перед началом установки WinNTSetup задаст вопрос о программе установки загрузчика и "по-умолчанию" предложит bootsect.exe. Принимаем это предложение.
Необходимо дождаться окончания подготовки файлов, о чем WinNTSetup сообщит и предложит перезагрузить PC.
После перезагрузки PC установка Windows начнется уже в "штатном" режиме.


4.18. Ошибка Gimagex: "Opening WIM...please wait... ERROR: Unable to mount image."

1. Убедиться, что в системе включен показ "расширений" файлов (.xxx), если нет - включить.
2. Создать текстовый файл clean.txt с содержимым:
@echo off
for /f "tokens=1" %%i in ('tasklist ^| findstr /i "gimagex"') do (taskkill /f /im %%i >nul)
:check
echo.
reg query "HKLM\SOFTWARE\Microsoft\WIMMount\Mounted Images" >nul 2>&1
if errorlevel 1 (echo MOUNTED IMAGES NOT FOUND!&goto :exit)
echo START CLEANUP ...
reg delete "HKLM\SOFTWARE\Microsoft\WIMMount\Mounted Images" /f >nul 2>&1
:exit
echo.
pause
3. Переименовать файл "clean.txt" в "clean.cmd".
4. Закрыть Gimagex и запустить "clean.cmd" от имени Администратора.
5. Перезагрузить PC, удалить и создать заново каталог монтирования для wim-файла.


4.19. Как в вашей сборке увеличить размер диска Boot(X:)?

Физическое ограничение для RAM-диска MicroSoft, используемого для создания диска X:\, составляет 512Мб (значение WinPECacheThreshold 200) для сборок на базе ХР/2003 и 1024Мб (WinPECacheThreshold 400) для 7-ки и выше. Большее значение можно установить (оно будет отображаться в свойствах X:\).
Но реально при заполнении несжимаемыми данными (уточню - все внесенные данные на RAM-диск MicroSoft - сжимаются) более указанных размеров диск "переполняется" даже при достаточном количестве ОЗУ. Имхо, драйвер RAM-диска MicroSoft сделан очень рационально: даже если указать WinPECacheThreshold 400, то реальное потребление памяти при загрузке не увеличится, она будет потребляться только при заполнении диска (копировании туда данных/программ/драйверов). Причем (и это отличительная черта именно MicroSoft-вского драйвера!) при удалении добавленных данных задействованная под них память освобождается и возвращается системе.
К примеру, ходовой ImDisk память в систему не возвращает, а Primo RAM disk возвращает, но не полностью.
Итог: под РЕ на базе 7-10 вполне можно указать WinPECacheThreshold 400 (и даже больше - хотя тут мало практической пользы), влияния на потребление памяти сборкой при запуске это не оказывает. Это значение нужно указать ДО загрузки, поскольку RAM-диск X:\ создается при запуске РЕ (т.е., значение должно быть указано в wim-ядре). Но, если памяти (ОЗУ) мало, то даже при незначительном заполнении данными X:\ туда нельзя будет записать что-либо (хотя циферку будет показывать "правильную" - мол, на X:\ места 1Гб).
К примеру, на ПК с ОЗУ 1Гб при загрузке примерно 300Мб "отъест" само ядро, примерно 200-300 Мб занимает ОС в памяти плюс программный пакет (если он копируется на X:\) - ещё 200-300Мб. Т.е., под данные на RAM-диске остается очень мало, 100-200Мб. Если это понимать (что чудес не бывает, и нельзя при 1Гб ОЗУ сделать реальный размер RAM-диска больше свободной памяти - тот же 1Гб), то можно менять...
Применительно к сборке Boot CD USB Sergei Strelec на базе Windows 8.0:
Размер RAM диска устанавливается в реестре по пути:
[HKEY_LOCAL_MACHINE\System\ControlSet001\Services\FBWF]
Параметр "WinPECacheThreshold":
Если значение = 400, то это означает 1024Мб, значение = 300 означает 768Мб, значение = 200 означает 512Мб, значение = 100 означает 256Мб.
Если удалить вообще параметр "WinPECacheThreshold", то размер RAM диска будет 32МБ, то есть по умолчанию.
Применительно к сборке Boot CD USB Sergei Strelec на базе Windows 8.1:
Размер RAM диска определяется файлом fbwf.cfg расположенном в корне папки Windows, находящейся в ядре сборки (*.wim).
По умолчанию в моих сборках размер RAM диска х86 образа равен 512 МБ, х64 образа 1024 МБ.
Для изменения размера RAM диска, необходимо скачать архив sstr_fbwf.cfg.zip и заменить в ядре сборки файл "Windows\fbwf.cfg" на нужный вам файл из архива, предварительно преименовав этот файл в fbwf.cfg
Перепаковать ядро проще всего с помощью бесплатного архиватора 7zip версии не ниже 9.38b.
Так же для перепаковки ядра можно использовать программу Gimagex (несколько сложнее).
Примечание: образы х86 не поддерживают размер RAM диска более 1024 МБ.


4.20. Как в вашей сборке заменить обои на "Рабочем Столе" на собственные, но без изменения WIM-файла?

Для сборок на базе Windows 8.0:
Начиная с v6.8 достаточно в папку SSTR\RESOURCES положить свои обои под названием wallpaper.jpg.
Для сборок на базе Windows 8.1-Windows 10:
В сборках на базе этих "ядер" механизм простой замены рисунка рабочего стола пока что не задействован, но несложный выход из этой ситуации есть.
С помощью архиватора 7zip версии от 16.xx и выше нужно открыть "ядра" (файлы "sterlec***.wim") как обычные архивы и заменить там файл "Windows\web\wallpaper\Windows\img0.jpg" на свой собственный рисунок, переименовав его в img0.jpg.


Работа с загрузочным диском WinPE 10-8 Sergei Strelec
Справочное руководство
×

  • 4. Часто задаваемые вопросы (F.A.Q) - Автор Sergei Strelec
  • 4.21. Как загрузить вашу сборку если на PC не установлена Windows, нет Floppy и CD-DVD приводов и BIOS не поддерживает загрузку с флешки?
  • Предыдущая
  • Следующая

4.21. Как загрузить вашу сборку если на PC не установлена Windows, нет Floppy и CD-DVD приводов и BIOS не поддерживает загрузку с флешки?

Вариант №1: Купить CD-DVD привод и загружать сборку с него (рекомендуется)
Вариант №2: Подключить HDD на другой(полноценный) PC, починить/установить загрузчик, добавить возможность загружать сборку, вернуть HDD обратно.


4.22. Как добавить к вашей сборке какой-нибудь дистрибутив Linux Live?

Рассмотрим решение вопроса на примере двух небольших дистрибутивов:
1. Runtu (Русский)
2. Parted Magic 2015.05.04 [x86/x64] (Английский)
Для Runtu:
1. Перейти на сайт Runtu и скачать актуальный образ диска с дистрибутивом(обычно это iso-файл, например: runtu-xfce-14.04_20140514.iso)
2. Создать в "корне" вашей загрузочной флешки каталог "linux", и каталог "runtu" внутри него.
3. Открыть в "UltraIso" или "7zip" файл "runtu-xfce-14.04_20140514.iso", извлечь из находящегося там каталога "casper" в каталог "/linux/runtu" (на флешке) два файла: "vmlinuz" и "initrd.lz".
4. Закрыть программы "UltraIso" или "7zip" (смотря чем открывали файл-образ).
5. Скопировать на флешку в каталог "/linux/runtu" файл "runtu-xfce-14.04_20140514.iso" и переименовать его там в какое-нибудь более короткое имя, например: runtu1404.iso
6. Перейти в каталог "SSTR" на флешке, открыть в "AkelPad" или "Notepad++" файл "menu.lst" и добавить туда следующее:
iftitle [if exist /linux/runtu/runtu1404.iso] Boot Runtu 14.04
set d=linux/runtu
kernel /%d%/vmlinuz iso-scan/filename=/%d%/runtu1404.iso boot=casper nopersistent ignore_uuid locale=ru_RU.UTF-8 console-setup/layoutcode=ru noeject noprompt quiet splash --
initrd /%d%/initrd.lz
7. Сохранить изменения, сделанные в файле "menu.lst" и можно пробовать загрузиться в Linux(пункт в меню: Boot Runtu 14.04 Live)
Примечание: Данный способ загрузки позволяет загружать даже "фрагментированный" образ.
Полезный ресурс по теме: http://greenflash.su/forum/6
Для Parted Magic:
1. Cкачать актуальный образ диска с дистрибутивом(обычно это iso-файл, например: pmagic_2015_05_04.iso)
2. Создать в "корне" вашей загрузочной флешки каталог "linux", и каталог "pmagic" внутри него.
3. Скопировать на флешку в каталог "/linux/pmagic" файл "pmagic_2015_05_04.iso" и переименовать его там в какое-нибудь более простое имя, например: "parted_magic.iso"
4. Перейти в каталог "SSTR" на флешке, открыть в "AkelPad" или "Notepad++" файл "menu.lst" и добавить туда следующее:
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic Linux
find --set-root /SSTR/pmagic_linux.lst
configfile /SSTR/pmagic_linux.lst
5. Создать в каталогe "SSTR" на флешке новый текстовый документ, переименовать его в "pmagic_linux.lst", открыть его в "AkelPad" или "Notepad++" и добавить туда следующее:
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x86 (Runs from RAM, 1Gb+)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m32.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x64 (Runs from RAM, 1Gb+)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage64 iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m64.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x86 (Live, 512Mb-1Gb)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal boot=live eject=no vmalloc=512MiB keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m32.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x64 (Live, 512Mb-1Gb)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage64 iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal boot=live eject=no vmalloc=512MiB keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m64.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x86 (Failsafe)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal vmalloc=512MiB acpi=off irqpoll noapic noapm nodma nomce nolapic nosmp nomodeset keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m32.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] Parted Magic x64 (Failsafe)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage64 iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal vmalloc=512MiB acpi=off irqpoll noapic noapm nodma nomce nolapic nosmp nomodeset keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m64.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] XVESA x32 (Alternate graphical server)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal xvesa=yes vmalloc=512MiB keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m32.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] XVESA x64 (Alternate graphical server)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/pmagic/bzImage64 iso_filename=/%d%/Parted_Magic.iso edd=on vga=normal xvesa=yes vmalloc=512MiB keymap=ru:-option~grp!ctrl_shift_toggle,grp_led!scroll~us,ru!:LatArCyrHeb-16
initrd (0xff)/pmagic/initrd.img (0xff)/pmagic/fu.img (0xff)/pmagic/m64.img
#
iftitle [if exist /linux/pmagic/parted_magic.iso] MHDD (HDD diagnostic and repair tool)
set d=linux/pmagic
map /%d%/Parted_Magic.iso (0xff)
map --hook
kernel (0xff)/boot/syslinux/memdisk iso_filename=/%d%/Parted_Magic.iso
initrd (0xff)/boot/mhdd/mhdd.gz
#
title [<< Main Menu]
find --set-root /SSTR/menu.lst
configfile /SSTR/menu.lst
#
Примечание: Образ "Parted_Magic.iso" после копирования на флешку должен быть "дефрагментирован", иначе не загрузится.


4.23. Как добавить в меню вашей основной сборки загрузку "Acronis Boot CD/USB Sergei Strelec"?

Рассмотрим решение на примере добавления Acronis Boot CD/USB Sergei Strelec (x64) в сборку Boot USB Sergei Strelec 2015 v.7.6
Добавлять будем на флешку объемом от 2(4) до 32gb включительно, размеченную в один раздел и отформатированную в FAT-32.
Примечания:
1. Для Windows_10 работоспособность скрипта не проверялась и не гарантируется.
2. Работа скрипта на ОС с языком , отличным от RU или ENG НЕ проверялась и НЕ гарантируется.
Порядок действий:
1. Скачать образы "Boot USB Sergei Strelec 2015 v.7.6" и "Acronis Boot CD/USB Sergei Strelec (x64)"
2. Записать образ "Boot USB Sergei Strelec 2015 v.7.6" на загрузочную флешку (рекомендуемым автором сборки способом) и проверить ее работоспособность.
3. Если проверка прошла успешно, то открываем образ "Acronis Boot CD/USB Sergei Strelec (x64)" с пом. 7zip v16.xx или UltraIso и извлекаем оттуда файл "acronis64.wim"
в каталог "\SSTR" недавно записанной загрузочной флешки.
4. Меню "Пуск" - "Панель управления" - "Параметры папок" -вкладка "Вид" -поле "Дополнительные параметры" -пункт "Скрывать расширения для зарегистрированных типов файлов"
Необходимо снять отметку с указанного пункта и нажать "Ок", с этого момента расширения файлов будут отображаться.
5. Создать в корне загрузочной флешки текстовый файл, переименовать его 1.bat и открыть его с помощью блокнота.
6. Скопировать КОД в открытый "1.bat" и сохранить изменения.
7. Запустить файл "1.bat" от имени Администратора и дождаться окончания его работы.
8. Теперь Acronis Boot CD/USB Sergei Strelec (x64) будет доступен из загрузочного меню BOOTMGR (будет последним в списке)
9. Т.к. файл "1.bat" больше не нужен, то его можно удалить с флешки .
Код для копирования в 1.bat:
@echo off
REM ****************************************************
set MENU-ITEM="Acronis Boot CD/USB Sergei Strelec (x64)"
set PATH-TO-BCD="SSTR\BCD"
set PATH-TO-WIM="SSTR\acronis64.wim"
REM ****************************************************
cd /d "%~dp0"
cls & echo.
set Bcdedit=%SYSTEMROOT%\System32\bcdedit.exe
if not exist %Bcdedit% (goto :wtf)
%Bcdedit% /store %PATH-TO-BCD% /create {ramdiskoptions}
%Bcdedit% /store %PATH-TO-BCD% /set {ramdiskoptions} ramdisksdidevice boot
%Bcdedit% /store %PATH-TO-BCD% /set {ramdiskoptions} ramdisksdipath \SSTR\boot.sdi
reg query "HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion" /v "CurrentVersion" | find "6.1" >nul
if %errorlevel% EQU 0 (set /a OST=0) else (set /a OST=1)
%Bcdedit% /? /createstore | find /i "Example:" >nul
if %errorlevel% EQU 0 (set /a VAL=3) else (set /a VAL=2)
for /F "tokens=%VAL%" %%i in ('%Bcdedit% /store %PATH-TO-BCD% /create /application osloader') do (
%Bcdedit% /store %PATH-TO-BCD% /set %%i description %MENU-ITEM%
%Bcdedit% /store %PATH-TO-BCD% /set %%i systemroot \Windows
%Bcdedit% /store %PATH-TO-BCD% /set %%i detecthal Yes
%Bcdedit% /store %PATH-TO-BCD% /set %%i winpe Yes
%Bcdedit% /store %PATH-TO-BCD% /set %%i osdevice ramdisk=[boot]\\%PATH-TO-WIM%,{ramdiskoptions}
%Bcdedit% /store %PATH-TO-BCD% /set %%i device ramdisk=[boot]\\%PATH-TO-WIM%,{ramdiskoptions}
%Bcdedit% /store %PATH-TO-BCD% /set %%i path \Windows\system32\boot\winload.exe
%Bcdedit% /store %PATH-TO-BCD% /set %%i locale ru-RU
%Bcdedit% /store %PATH-TO-BCD% /set %%i testsigning on
if %OST% EQU 1 (%Bcdedit% /store %PATH-TO-BCD% /set %%i bootmenupolicy Legacy)
%Bcdedit% /store %PATH-TO-BCD% /displayorder %%i /addlast
echo. & echo GUID: %%i & echo.
goto :exit
)
:wtf
cls & echo. & color 0C
echo File: %SYSTEMROOT%\System32\bcdedit.exe NOT FOUND! & echo.
:exit
pause
exit
Важно: Для загрузки в режиме т.н "чистого" EFI (без Legacy) используется файл "\EFI\microsoft\boot\BCD" а не "\SSTR\BCD"


4.24. Как самостоятельно обновить программу SmartFix в вашей сборке?

Так как обновление сборки "Boot CD/USB Sergei Strelec" не всегда совпадает с выходом новой версии "SmartFix" - рекомендуется освоить следующие несложные шаги:
1. Посетить сайт разработчика программы SmartFix и скачать файл "SmartFix.exe".
2. Скачать актуальный образ сборки Boot USB Sergei Strelec и открыть его в программе UltraIso.
3. Перейти в каталог "\SSTR\SmartFix", удалить "старый" файл SmartFix.exe и скопировать на его место "новую" версию файла.
4. Перейти в меню "Файл" и выбрать пункт "Сохранить", дождаться окончания создания нового образа и закрыть UltraIso.
SmartFiх имеет встроенный механизм обновления. При старте программа проверяет в интернете наличие обновления и, если оно найдено - предлагает пррименить обновление. Если разрешить, то программа обновится автоматически.
Примечание: Для тех, у кого сборка "Boot CD USB Sergei Strelec" уже распакована на флешку - достаточно выполнить пункт №1 и затем №3 (на флешке).


4.25. Как добавить в вашу сборку возможность использования языка ввода и раскладки клавиатуры, отличных от Русского и Английского?

За это отвечают KBD**.dll-ки. Их можно взять в дистрибутиве Windows (в каталоге "\Windows\system32") и добавить в каталог "\Windows\system32" уже в ядре (*.wim) сборки.
Например если вам нужен украинский - добавляете KBDUR.DLL.
Затем можно создать командный файл ("My_Keyboard.cmd") с таким содержимым:
@echo off & wpeutil SetKeyboardLayout 0422:00000422 & exit
Затем необходимо скопировать этот файл в "корень" каталога "SSTR".
После загрузки в WinPE нужно перейти в каталог SSTR и запустить этот самый файл "My_Keyboard.cmd" и у вас появится украинская раскладка. И т.д.


4.26. Как внести собственные изменения/дополнения в реестр вашей сборки?

Загрузка куста реестра:
Чтобы загрузить или выгрузить куст реестра, используйте редактор реестра.
Команды "Загрузить куст" и "Выгрузить куст" применимы только к разделам "HKEY_USERS" и "HKEY_LOCAL_MACHINE" и активны только тогда, когда выбраны эти стандартные разделы.
При загрузке куста в реестр куст становится подразделом одного из этих разделов.
1. Откройте редактор реестра ("Пуск"→Выполнить→regedit→"ОК")
2. Выберите раздел "HKEY_USERS" или "HKEY_LOCAL_MACHINE".
3. В меню Файл выберите команду "Загрузить куст".
4. Выберите куст, который нужно загрузить.
5. Нажмите кнопку "Открыть".
6. В поле "Имя раздела" введите имя (произвольное), которое необходимо присвоить кусту, и нажмите "ОК".
7. Внесите необходимые изменения в реестр.
Выгрузка куста реестра:
1. Откройте редактор реестра ("Пуск"→Выполнить→regedit→"ОК")
2. Выберите раздел "HKEY_USERS" или "HKEY_LOCAL_MACHINE".
3. Выберите куст, ранее загруженный вами в систему.
4. В меню "Файл" выберите команду "Выгрузить куст".
Применяем вышеуказанные рекомендации к сборке Boot CD USB Sergei Strelec:
1. Извлечь (с помощью 7zip v16.xx) из "/SSTR/strelec8*.WIM" файл "\Windows\System32\config\SYSTEM" и загрузить его как куст реестра.
3. Внести/добавить нужные вам значения в раздел "HKEY_USERS" или "HKEY_LOCAL_MACHINE" и выгрузить куст реестра.
4. Заменить в сборке (с помощью 7zip v16.xx) в "/SSTR/strelec8*.WIM" файл "\Windows\System32\config\SYSTEM" на "выгруженный" вами файл "SYSTEM"
5. Загрузить сборку на PC и проверить результат от внесенных вами изменений.
Примечание: Оригинальные рекомендации от MS можно посмотреть здесь .


4.27. Как можно сделать экспорт/импорт WLAN-профилей, чтобы не вводить данные каждый раз вручную?

Все сохраненные WLAN профили на компьютере хранятся в папке "ProgramData\Microsoft\Wlansvc\Profiles\Interfaces". Ключ находится там как параметр keyMaterial в зашифрованном виде, выглядит как длинный набор букв и цифр.
Команда экспорта профиля выглядит так: netsh wlan export profile key=clear (key=clear расшифровывает ключ при экспорте). Это стандартная команда от Microsoft для сохранения профилей, а затем их применения при переустановке ОС например, чтоб не вводить все заново.
Поэтому "батник" должен выполнятся от имени Администратора, иначе ключ просто не расшифруется и работать не будет. То есть в образ он должен быть помещен в расшифрованном виде, то есть его реальное значение, иначе он правильно работать не будет. При импорте профиля он опять шифруется системой.
Автоматизация экспорта и импорта профилей:
1. Включить показ расширений для зарегистрированных типов файлов.
2. Создать папку с именем WLAN и в ней создать два текстовых файла: export.bat и import.bat.
3. Открыть в блокноте файл export.bat, скопировать код для export.bat и вставить его в открытый export.bat. Сохранить изменения в файле.
4. Открыть в блокноте файл import.bat, скопировать код для import.bat и вставить его в открытый import.bat. Сохранить изменения в файле.
5. Перенести папку WLAN на PC, с которого нужно экспортировать профили, перейти в нее и запустить с правами Администратора файл export.bat.
6. В появившемся каталоге WLAN\_WLANProfiles должны будут появится XML-файлы с профилями, определите нужный вам профиль(или профили) и удалите не нужные.
7. Перенести папку WLAN на PC, на который нужно экспортировать профили, перейти в нее и запустить с правами Администратора файл import.bat.
8. Если папка WLAN\_WLANProfiles более не нужна, то ее можно удалить.
Содержимое export.bat:
@echo off
set wpdir=%~dp0_WLANProfiles
if not exist "%wpdir%" mkdir "%wpdir%"
netsh wlan export profile key=clear folder="%wpdir%"
cd /d "%wpdir%"
for /f "delims=" %%i in ('dir /a:-d /b') do (
for /f "delims=- tokens=2" %%j in ('echo %%i') do (
move /y "%%i" "%%j"
)
)
pause
exit
Содержимое import.bat:
@echo off
set wpdir=%~dp0_WLANProfiles
cd /d "%wpdir%"
for /f "delims=" %%i in ('dir /a:-d /b') do (
netsh wlan add profile filename="%%i" user=all
)
pause
exit


4.28. Я нашел/написал по-моему потрясающую программу/скрипт. Как выложить ее на вашем сайте?

1. Сайт не является торрент-трекером (и.т.п), поэтому следует быть "умеренным в усердии своем".
2. Нужно упаковать программу/скрипт + описание + "скриншоты" к ней в ZIP-архив и сохранить этот архив на один из (достойных по вашему мнению) бесплатных файлообменников .
3. Прислать ссылку на скачивание этого архива администрации форума. Если программа работоспособна, полезна и соответствует тематике сайта - тогда есть шанс, что она появится на сайте.
Примечание: Степень полезности и соответствие тематике в данном случе определяется не релизером или автором программы, а администрацией сайта.


4.29. Зачем нужны патчи-обновления для вашей сборки и как применять эти патчи?

Общие сведения о патчах:
Для примера возьмем образ DVD-диска (~3.7Gb) с сложным программным обеспечением (П.O)
Разработчик регулярно вносит обновления или изменения в П.O и собирает обновленный образ для скачивания (~3.7Gb). Зачастую "чистый" размер вносимых в П.О изменений может насчитывать от 100 до 500 мегабайт, а приходится скачивать весь образ (~3.7Gb). Бывает, что тарифный план (или качество интернет-канала) оставляют желать лучшего, а потребность в актуальных обновлениях очень высока. В таких случаях удобно обновляться Патчами.
Патчи изготавливают с помощью "Конструктора Патчей" - специальной программы, которая позволяет сравнить исходный и обновленный файлы, извлечь из них только разницу и изготовить исполняемый файл, умеющий корректно добавить эту разницу в исходный файл.
Соответственно, размер скачиваемого обновления в 100 или пусть даже 500Mb ощутимо меньше 3.7Gb, что хорошо в случае с "плохим" интернетом. Вместо скачивания "полноразмерного" файла можно своевременно скачивать только соответствующие Патчи и правильно применять их. При таком подходе исходный (~3.7Gb) файл скачивается пользователем только один раз.
Основные типы патчей для сборки Boot USB Sergei Strelec:
1. Переходный патч - обычно нужен для обновления предыдущей версии сборки до следующей, например от v7.7 до v7.8
2. Сплит(split) патч - выделяет из полной сборки только x86 или только х64 версию, дополнительно может содержать в себе те или иные неофициальные изменения для оригинальной сборки. Этот патч является "опцией" (необязательным) и не поддерживается автором сборки.
Применение переходного патча:
1. Если патч был упакован в архив (.7z, .zip, .rar) - извлечь патч из архива в каталог с "старым" файлом-образом(.iso), к которому нужно применить патч.
2. Запустить патч (на Windows 7-10 от имени Администратора).
3. Дождаться окончания применения патча(будет сообщение).
4. "Новый" образ будет находиться рядом со "старым" файлом-образом.
Примечания:
1. Применение Сплит (split) патча полностью аналогично применению переходного патча.
2. Рекомендуемый "Конструктор Патчей": Mole's Smartversion Patch Constructor v2.2


4.30. Как добавить в вашу сборку образ Kaspersky Rescue Disk 10?

Обычный вариант загрузки:
1. Скачать образ Kaspersky Rescue Disk 10
2. Сделать копию файла "kav_rescue_10.iso" и переименовать ее в rescueusb.iso, а оригинал переименовать в "rescue.iso"
3. Открыть файл "rescueusb.iso" в программе "UltraISO" и удалить там каталог "rescue" и файл "livecd". Сохранить изменения в файлe "rescueusb.iso".
4. На флешке создать папку "rescue" (если таковая отсутствует) и скопировать в нее файлы "rescueusb.iso" и "rescue.iso". Если там уже были такие файлы - согласиться на замену.
5. В "корне" флешки создаем пустой текстовый файл "liveusb" (если таковой отсутствует), обязательно без расширения (без ".txt").
6. Проверяем в файле "/SSTR/menu.lst" наличие нижеследующих строк - если их нет, то добавляем:
iftitle [if exist /rescue/rescue.iso] Kaspersky Rescue Disk 10
find --set-root --ignore-floppies /rescue/rescueusb.iso
map /rescue/rescueusb.iso (0xff) || map --mem /rescue/rescueusb.iso (0xff)
map --hook
chainloader (0xff)
Примечание: При замене "kav_rescue_10.iso" на его новую версию требуется пересоздание "rescueusb.iso", так как версии образов должны совпадать.
Альтернативный вариант загрузки:
1. Скачать образ Kaspersky Rescue Disk 10
2. Переименовать "kav_rescue_10.iso" в "rescue.iso".
3. На флешке создаем папку rescue (если таковая отсутствует) и копируем в нее файл "rescue.iso". Если там уже был такой файл - соглашаемся на замену.
4. В "корне" флешки создаем пустой текстовый файл "liveusb" (если таковой отсутствует), обязательно без расширения (без ".txt").
5. Проверяем наличие в файле "/SSTR/menu.lst" наличие следующих строк - если их нет, то добавляем:
iftitle [if exist /rescue/rescue.iso] Kaspersky Rescue Disk 10 (alt)
set KRD10ISO=/rescue/rescue.iso
set kernel=(0xff)/boot/rescue root=live:UUID=A1234-1234 rootfstype=auto vga=791 init=/init kav_lang=ru udev liveimg splash quiet doscsi nomodeset
set initrd=(0xff)/boot/rescue.igz
map %KRD10ISO% (0xff) || map --mem %KRD10ISO% (0xff)
map --hook > nul
kernel %kernel%
initrd %initrd%
boot


4.31. Как установить/переустановить Windows с помощью вашей сборки?

Рассмотрим самый простой и универсальный способ, который доступен любому, даже начинающему пользователю.
Нижеследующее руководство справедливо только для оригинальных дистрибутивов от Microsoft, модифицированные дистрибутивы Windows не рассматриваются - все вопросы к их авторам.
1. Скопировать необходимый ISO-образ с системой на флешку. Туда же можно скопировать ключи для установки, если они требуются.
2. Для установки х86 (32х-битной) системы вам необходимо загрузиться с "WinPE-х86", а для установки х64 (64х-битной) системы соответственно с "WinPE-х64"
3. После загрузки WinPE вы можете предварительно подготовить HDD, создать, изменить разделы, протестировать диск, сделать бэкап предыдущей системы и т.д.
4. Открываете в "Проводнике" флешку с ISO-образом (см. пункт №1), щелкаете по образу правой кнопкой мышки, и из контекстного меню выбираете: "Монтировать как ImDisk Virtual Disk".
5. Двойной клик левой кнопкой мыши по значку "Мой компьютер" на "Рабочем столе" и в "Проводнике" должен быть виден смонтированный в виртуальный CD/DVD-привод образ.
6. Открываете смонтированный образ как обыкновенную папку и запускаете файл "setup.exe".
7. Производите стандартную установку Windows на нужный вам раздел или диск.
Примечание:
Рекомендуется дополнительно форматировать раздел или диск, куда вы устанавливаете систему, прямо в программе установки (будет предложено установщиком на этапе подготовки диска).
Особенно если вы создавали или форматировали перед этим раздел/диск сторонними менеджерами разделов (Acronis DD и.т.п). Случается, что программа установки "не дружит" сторонней разметкой. Лучше лишний раз перестраховаться.


4.32. Почему в режиме UEFI ваша сборка (x64) загружается, а (x86) не хочет, хотя на планшетах ситуация обратная?

  • 1.
    В режиме UEFI версия WinPE должна соответствовать архитектуре компьютера.
  • 2.
    На компьютерах в режиме UEFI на базе 64-разрядной архитектуры можно загрузить только 64-разрядные версии WinPE.
  • 3.
    На компьютерах в режиме UEFI на базе 32-разрядной архитектуры можно загрузить только 32-разрядные версии WinPE.
  • 4.
    Если компьютер поддерживает и режим UEFI, и прежний Legacy BIOS, то можно запустить 32-разрядную WinPE на 64-разрядном компьютере, изменив в настройках BIOS режим "UEFI" на режим "Legacy BIOS" (естественно, если эта возможность предусмотрена производителем PC).
Оригинал статьи на msdn.microsoft.com